<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<title>Frozen 2 To Make Early Debut on Disney+! | EclipseMagazine</title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://eclipsemagazine.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="http://eclipsemagazine.com/wp-content/themes/twentyfourteen/js/html5.js"></script>
	<![endif]-->
	<script type='text/javascript'>function ctSetCookie(c_name, value, def_value){document.cookie = c_name + '=' + escape(value) + '; path=/';}ctSetCookie('ct_checkjs', '1294115772', '0');</script><link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="EclipseMagazine &raquo; Feed" href="http://eclipsemagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="EclipseMagazine &raquo; Comments Feed" href="http://eclipsemagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="EclipseMagazine &raquo; Frozen 2 To Make Early Debut on Disney+! Comments Feed" href="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/eclipsemagazine.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='twentyfourteen-jetpack-css'  href='https://c0.wp.com/p/jetpack/8.1.1/modules/theme-tools/compat/twentyfourteen.css' type='text/css' media='all' />
<!-- `jetpack_related-posts` is included in the concatenated jetpack.css -->
<link rel='stylesheet' id='pfc-style-css'  href='http://eclipsemagazine.com/wp-content/plugins/posts-from-category/assets/pfc-style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<!-- `jetpack_likes` is included in the concatenated jetpack.css -->
<link rel='stylesheet' id='twentyfourteen-lato-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900%2C300italic%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://c0.wp.com/p/jetpack/8.1.1/_inc/genericons/genericons/genericons.css' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfourteen-style-css'  href='http://eclipsemagazine.com/wp-content/themes/twentyfourteen/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfourteen-block-style-css'  href='http://eclipsemagazine.com/wp-content/themes/twentyfourteen/css/blocks.css?ver=20181230' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfourteen-ie-css'  href='http://eclipsemagazine.com/wp-content/themes/twentyfourteen/css/ie.css?ver=20131205' type='text/css' media='all' />
<![endif]-->
<!-- `sharedaddy` is included in the concatenated jetpack.css -->
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.1.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.1.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript' src='http://eclipsemagazine.com/wp-content/plugins/posts-from-category/assets/pfc-custom.js?ver=4.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctPublic = {"_ajax_nonce":"a01ce65dca","_ajax_url":"http:\/\/eclipsemagazine.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://eclipsemagazine.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js?ver=5.133.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctNocache = {"ajaxurl":"http:\/\/eclipsemagazine.com\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"","blog_home":"http:\/\/eclipsemagazine.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://eclipsemagazine.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_nocache.min.js?ver=5.133.1'></script>
<link rel='https://api.w.org/' href='http://eclipsemagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://eclipsemagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://eclipsemagazine.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Coronavirus Changes Movie Dates!' href='http://eclipsemagazine.com/coronavirus-changes-movie-dates/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/" />
<link rel='shortlink' href='https://wp.me/paxfV-nYS' />
<link rel="alternate" type="application/json+oembed" href="http://eclipsemagazine.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Feclipsemagazine.com%2Ffrozen-2-to-make-early-debut-on-disney%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://eclipsemagazine.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Feclipsemagazine.com%2Ffrozen-2-to-make-early-debut-on-disney%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>		<style type="text/css" id="twentyfourteen-header-css">
				.site-title,
		.site-description {
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
			position: absolute;
		}
				</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #550000; background-image: url("http://eclipsemagazine.com/wp-content/uploads/2014/05/bg_body.png"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: fixed; }
</style>
				<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Frozen 2 To Make Early Debut on Disney+!" />
<meta property="og:url" content="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/" />
<meta property="og:description" content="The Walt Disney Company has announced that Frozen 2 will debut on Disney+ three months early." />
<meta property="article:published_time" content="2020-03-14T03:50:03+00:00" />
<meta property="article:modified_time" content="2020-03-14T03:50:03+00:00" />
<meta property="og:site_name" content="EclipseMagazine" />
<meta property="og:image" content="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?fit=1194%2C500" />
<meta property="og:image:width" content="1194" />
<meta property="og:image:height" content="500" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@EclipseMagazine" />
<meta name="twitter:text:title" content="Frozen 2 To Make Early Debut on Disney+!" />
<meta name="twitter:image" content="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?fit=1194%2C500&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
</head>

<body class="post-template-default single single-post postid-92186 single-format-standard custom-background wp-embed-responsive group-blog header-image singular">
<div id="page" class="hfeed site">
		<div id="site-header">
		<a href="http://eclipsemagazine.com/" rel="home">
			<img src="http://eclipsemagazine.com/wp-content/uploads/2014/05/cropped-eclipse-header.jpg" width="1260" height="240" alt="EclipseMagazine">
		</a>
	</div>
	
	<header id="masthead" class="site-header" role="banner">
		<div class="header-main">
			<h1 class="site-title"><a href="http://eclipsemagazine.com/" rel="home">EclipseMagazine</a></h1>

			<div class="search-toggle">
				<a href="#search-container" class="screen-reader-text" aria-expanded="false" aria-controls="search-container">Search</a>
			</div>

			<nav id="primary-navigation" class="site-navigation primary-navigation" role="navigation">
				<button class="menu-toggle">Primary Menu</button>
				<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
				<div class="menu-header-menu-container"><ul id="primary-menu" class="nav-menu"><li id="menu-item-47078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47078"><a href="http://eclipsemagazine.com/category/geekscholars/">GeekScholars</a></li>
<li id="menu-item-47079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47079"><a href="http://eclipsemagazine.com/category/hollywood-insider/">Hollywood Insider</a></li>
<li id="menu-item-47080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47080"><a href="http://eclipsemagazine.com/category/movienews/">Movie News</a></li>
<li id="menu-item-47081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47081"><a href="http://eclipsemagazine.com/category/movie-reviews/">Movie Reviews</a></li>
<li id="menu-item-47082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47082"><a href="http://eclipsemagazine.com/category/movie-trailers/">Movie Trailers</a></li>
<li id="menu-item-47083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47083"><a href="http://eclipsemagazine.com/category/out-and-about/">Out and About</a></li>
<li id="menu-item-47084" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-47084"><a href="http://eclipsemagazine.com/category/television/">Television</a></li>
<li id="menu-item-47085" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47085"><a href="http://eclipsemagazine.com/category/tv-reviews/">TV Reviews</a></li>
<li id="menu-item-47086" class="subscribelink menu-item menu-item-type-custom menu-item-object-custom menu-item-47086"><a href="http://eclipsemagazine.com/feed">Subscribe</a></li>
</ul></div>			</nav>
		</div>

		<div id="search-container" class="search-box-wrapper hide">
			<div class="search-box">
				<form role="search" method="get" class="search-form" action="http://eclipsemagazine.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</div>
		</div>
	</header><!-- #masthead -->

	<div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">
			
<article id="post-92186" class="post-92186 post type-post status-publish format-standard has-post-thumbnail hentry category-television tag-disney tag-frozen-2 tag-idina-menzel tag-kristen-bell tag-television">
	
		<div class="post-thumbnail">
			<img width="672" height="372" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?resize=672%2C372" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="92187" data-permalink="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/frozen-2-6/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?fit=1194%2C500" data-orig-size="1194,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Walt Disney Animation Studios&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;From the Academy Award\u00ae-winning team\u2014directors Jennifer Lee and Chris Buck, and producer Peter Del Vecho\u2014and featuring the voices of Idina Menzel, Kristen Bell, Jonathan Groff and Josh Gad, and the music of Oscar\u00ae-winning songwriters Kristen Anderson-Lopez and Robert Lopez, Walt Disney Animation Studios\u2019 \u201cFrozen 2\u201d opens in U.S. theaters on Nov. 22, 2019. \r\r\u00a92019 Disney. All Rights Reserved.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a92019 Disney. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;FROZEN 2&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="FROZEN 2" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?fit=400%2C168" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?fit=474%2C199" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?zoom=2&amp;resize=672%2C372 1344w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?zoom=3&amp;resize=672%2C372 2016w" data-lazy-sizes="(max-width: 672px) 100vw, 672px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?resize=672%2C372&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />		</div>

		
	<header class="entry-header">
				<div class="entry-meta">
			<span class="cat-links"><a href="http://eclipsemagazine.com/category/television/" rel="category tag">Television</a></span>
		</div>
			<h1 class="entry-title">Frozen 2 To Make Early Debut on Disney+!</h1>
		<div class="entry-meta">
			<span class="entry-date"><a href="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/" rel="bookmark"><time class="entry-date" datetime="2020-03-13T23:50:03-04:00">March 13, 2020</time></a></span> <span class="byline"><span class="author vcard"><a class="url fn n" href="http://eclipsemagazine.com/author/swiebe5/" rel="author">Sheldon Wiebe</a></span></span>			<span class="comments-link"><a href="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/#respond">Leave a comment</a></span>
						</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

		<div class="entry-content">
		<p>The Walt Disney Company has announced that Frozen 2 will debut on Disney+ three months early.</p>
<p><span id="more-92186"></span></p>
<p style="font-weight: 400;"><strong>THE WALT DISNEY COMPANY WILL MAKE “FROZEN 2” AVAILABLE ON DISNEY+ THREE MONTHS EARLY, BEGINNING TUESDAY, MARCH 17</strong><strong> </strong></p>
<p style="font-weight: 400;"><strong><em>Disney+ Adds ‘Frozen 2’ Early for Families During These Challenging Times</em></strong></p>
<p style="font-weight: 400;">BURBANK, Calif. (March 13, 2020) –The Walt Disney Company (NYSE: DIS) announced that “Frozen 2” will be available three months ahead of schedule on Disney+ in Canada beginning Tuesday, March 17, surprising families with some fun and joy during this challenging period.</p>
<p style="font-weight: 400;">“‘Frozen 2’ has captivated audiences around the world through its powerful themes of perseverance and the importance of family, messages that are incredibly relevant during this time, and we are pleased to be able to share this heartwarming story early with our Disney+ subscribers to enjoy at home on any device,” said Bob Chapek, Chief Executive Officer, The Walt Disney Company.</p>
<p style="font-weight: 400;">The No. 1 animated movie of all time, “Frozen 2” follows Elsa, together with Anna, Kristoff, Olaf and Sven, on a remarkable and inspiring journey into the unknown to discover the source of her magical powers and save the kingdom of Arendelle. From Walt Disney Animation Studios and the Academy Award<sup>®</sup>-winning team of directors Jennifer Lee and Chris Buck, producer Peter Del Vecho, and songwriters Kristen Anderson-Lopez and Robert Lopez, “Frozen 2” features the voices of Idina Menzel, Kristen Bell, Jonathan Groff and Josh Gad.</p>
<p style="font-weight: 400;">“Frozen 2” joins Disney+’s lineup of blockbuster movies, original content, and classic library titles from Disney, Pixar, Marvel, Star Wars, National Geographic, and more.</p>
<p style="font-weight: 400;"><strong><u>“Frozen 2” Cast and Crew</u></strong></p>
<p style="font-weight: 400;">Kristen Bell (“The Good Place,” “Veronica Mars”), Idina Menzel (Broadway’s “Rent” and “Wicked,” “Uncut Gems”), Josh Gad (Broadway’s “The Book of Mormon,” “Little Monsters”) and Jonathan Groff (Broadway’s “Spring Awakening” and “Hamilton,” “Mindhunter”) return to Arendelle as the voices of Anna, Elsa, Olaf and Kristoff, respectively. Evan Rachel Wood (“Westworld,” “Mildred Pierce,” “The Wrestler”) joins the cast as Queen Iduna, Anna and Elsa’s mother, and Sterling K. Brown (“Waves,” “Black Panther,” “This Is Us”) portrays Lieutenant Destin Mattias. The film is directed by Chris Buck (“Frozen,” “Tarzan,” “Surfs Up”) and Jennifer Lee (Walt Disney Animation Studios’ chief creative officer, writer/director “Frozen,” writer “Frozen” Broadway, screenwriter “A Wrinkle in Time”). Lee also wrote the screenplay. The film is produced by Peter Del Vecho (“Frozen,” “The Princess and the Frog”) and executive produced by Byron Howard (“Zootopia”). Songwriters Kristen Anderson-Lopez (“Frozen” film/Broadway, Off-Broadway’s “In Transit”) and Robert Lopez (“Frozen” film/Broadway, Broadway’s “The Book of Mormon”) wrote seven all-new original songs for the film, and Christophe Beck, who scored “Frozen,” composed the score.</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Sharing is Caring:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/" data-text="Frozen 2 To Make Early Debut on Disney+!" data-via="EclipseMagazine" >Tweet</a></li><li class="share-reddit"><div class="reddit_button"><iframe src="http://www.reddit.com/static/button/button1.html?newwindow=true&width=120&amp;url=http%3A%2F%2Feclipsemagazine.com%2Ffrozen-2-to-make-early-debut-on-disney%2F&amp;title=Frozen%202%20To%20Make%20Early%20Debut%20on%20Disney%2B%21" height="22" width="120" scrolling="no" frameborder="0"></iframe></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Feclipsemagazine.com%2Ffrozen-2-to-make-early-debut-on-disney%2F&#038;media=https%3A%2F%2Fi2.wp.com%2Feclipsemagazine.com%2Fwp-content%2Fuploads%2F2020%2F03%2FFrozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg%3Ffit%3D1194%252C500&#038;description=Frozen%202%20To%20Make%20Early%20Debut%20on%20Disney%2B%21" data-pin-do="buttonPin" data-pin-config="beside"><img src="https://i2.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?w=474" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?w=474&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?w=474" data-recalc-dims="1" /></noscript></a></div></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-2511119-92186-5e6c54c22b4b0' data-src='https://widgets.wp.com/likes/#blog_id=2511119&amp;post_id=92186&amp;origin=eclipsemagazine.com&amp;obj_id=2511119-92186-5e6c54c22b4b0' data-name='like-post-frame-2511119-92186-5e6c54c22b4b0'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>	</div><!-- .entry-content -->
	
	<footer class="entry-meta"><span class="tag-links"><a href="http://eclipsemagazine.com/tag/disney/" rel="tag">Disney Film</a><a href="http://eclipsemagazine.com/tag/frozen-2/" rel="tag">Frozen 2</a><a href="http://eclipsemagazine.com/tag/idina-menzel/" rel="tag">Idina Menzel</a><a href="http://eclipsemagazine.com/tag/kristen-bell/" rel="tag">Kristen Bell</a><a href="http://eclipsemagazine.com/tag/television/" rel="tag">Television</a></span></footer></article><!-- #post-## -->
		<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">
			<a href="http://eclipsemagazine.com/coronavirus-changes-movie-dates/" rel="prev"><span class="meta-nav">Previous Post</span>Coronavirus Changes Movie Dates!</a>			</div><!-- .nav-links -->
		</nav><!-- .navigation -->
		
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/frozen-2-to-make-early-debut-on-disney/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://eclipsemagazine.com/wp-login.php?redirect_to=http%3A%2F%2Feclipsemagazine.com%2Ffrozen-2-to-make-early-debut-on-disney%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments -->
		</div><!-- #content -->
	</div><!-- #primary -->

<div id="content-sidebar" class="content-sidebar widget-area" role="complementary">
	<aside id="pfcwidget-9" class="widget pfc-widget">
		<div class="pfc-posts-wrap">

			<h1 class="widget-title">Hollywood Insider</h1>
			<div class="pfc-posts-inner">

				
		<div class="pfc-posts-main">

			
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/marlon-west-beyond-the-effects-of-frozen/"><img width="390" height="400" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?fit=390%2C400" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91267" data-permalink="http://eclipsemagazine.com/marlon-west-beyond-the-effects-of-frozen/marlon-3/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?fit=600%2C615" data-orig-size="600,615" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="marlon 3" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?fit=390%2C400" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?fit=474%2C486" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?w=600 600w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?resize=390%2C400 390w" data-lazy-sizes="(max-width: 390px) 100vw, 390px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?fit=390%2C400&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/marlon-west-beyond-the-effects-of-frozen/">Marlon West: Beyond the Effects of Frozen</a></h2>

					    <p>I have recently sat down with Marlon West, who is...</p>
	                		<a href="http://eclipsemagazine.com/marlon-west-beyond-the-effects-of-frozen/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/for-all-mankind-interviews-part-1/"><img width="400" height="225" src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?fit=400%2C225" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91028" data-permalink="http://eclipsemagazine.com/for-all-mankind-interviews-part-1/mv5bmjqyzwm2zgqtoguyzs00zty2ltk1odktyjzlnjdinmezzda0xkeyxkfqcgdeqxvynte1njy5mg-_v1_/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?fit=816%2C459" data-orig-size="816,459" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?fit=400%2C225" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?fit=474%2C267" data-lazy-srcset="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?w=816 816w, https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?resize=400%2C225 400w, https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?resize=768%2C432 768w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?fit=400%2C225&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/for-all-mankind-interviews-part-1/">For All Mankind Interviews Part 1</a></h2>

					    <p>Apple TV+ makes its debuts today in streaming media. One...</p>
	                		<a href="http://eclipsemagazine.com/for-all-mankind-interviews-part-1/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/terrence-blanchard-delivers-an-inspiring-score-to-a-maryland-legend/"><img width="400" height="320" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?fit=400%2C320" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91024" data-permalink="http://eclipsemagazine.com/terrence-blanchard-delivers-an-inspiring-score-to-a-maryland-legend/dsc_0485/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?fit=3170%2C2536" data-orig-size="3170,2536" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;6&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D5000&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1571573401&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;140&quot;,&quot;iso&quot;:&quot;6400&quot;,&quot;shutter_speed&quot;:&quot;0.125&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Blanchard1" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?fit=400%2C320" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?fit=474%2C379" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?w=3170 3170w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?resize=400%2C320 400w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?resize=768%2C614 768w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?resize=1024%2C819 1024w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?w=948 948w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?w=1422 1422w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?fit=400%2C320&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/terrence-blanchard-delivers-an-inspiring-score-to-a-maryland-legend/">Terrence Blanchard: Delivers an Inspiring Score to A Maryland Legend</a></h2>

					    <p>&nbsp; Film Composer Terence Blanchard is gearing up to bring...</p>
	                		<a href="http://eclipsemagazine.com/terrence-blanchard-delivers-an-inspiring-score-to-a-maryland-legend/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/cws-all-american-hunter-clowdus-talks-to-michelle/"><img width="400" height="238" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?fit=400%2C238" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="90828" data-permalink="http://eclipsemagazine.com/cws-all-american-hunter-clowdus-talks-to-michelle/cws-hunter-clowdus-wide/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?fit=624%2C371" data-orig-size="624,371" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CWs Hunter Clowdus Wide" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?fit=400%2C238" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?fit=474%2C282" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?w=624 624w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?resize=400%2C238 400w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?fit=400%2C238&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/cws-all-american-hunter-clowdus-talks-to-michelle/">CW&#8217;s All American Hunter Clowdus Talks To Michelle!</a></h2>

					    <p>I recently did an email interview with Hunter Clowdus, one...</p>
	                		<a href="http://eclipsemagazine.com/cws-all-american-hunter-clowdus-talks-to-michelle/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/john-travolta-from-being-a-fan-to-playing-a-fanatic/"><img width="400" height="300" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?fit=400%2C300" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="90341" data-permalink="http://eclipsemagazine.com/john-travolta-from-being-a-fan-to-playing-a-fanatic/v1-bjsymzewmtiwo2o7mtgymdy7mtiwmdsymja1oze2ntq/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?fit=1152%2C864" data-orig-size="1152,864" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?fit=400%2C300" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?fit=474%2C356" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?w=1152 1152w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?resize=400%2C300 400w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?resize=768%2C576 768w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?resize=1024%2C768 1024w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?w=948 948w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?fit=400%2C300&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/john-travolta-from-being-a-fan-to-playing-a-fanatic/">John Travolta: From Being a Fan to playing a Fanatic</a></h2>

					    <p>On this edition of the INTERVUE, legendary actor John Travolta...</p>
	                		<a href="http://eclipsemagazine.com/john-travolta-from-being-a-fan-to-playing-a-fanatic/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/giancarlo-esposito-talks-about-mandalorian-with-michelle/"><img width="400" height="225" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?fit=400%2C225" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="90336" data-permalink="http://eclipsemagazine.com/giancarlo-esposito-talks-about-mandalorian-with-michelle/giancarlo-esposito-mandaloria-2/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?fit=700%2C394" data-orig-size="700,394" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Giancarlo Esposito Mandaloria 2" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?fit=400%2C225" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?fit=474%2C267" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?w=700 700w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?resize=400%2C225 400w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?fit=400%2C225&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/giancarlo-esposito-talks-about-mandalorian-with-michelle/">Giancarlo Esposito Talks About Mandalorian with Michelle!</a></h2>

					    <p>One of the biggest surprises last month was the discovery...</p>
	                		<a href="http://eclipsemagazine.com/giancarlo-esposito-talks-about-mandalorian-with-michelle/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/why-women-kill-premieres-on-august-15-on-cbs-all-access/"><img width="400" height="300" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?fit=400%2C300" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="90224" data-permalink="http://eclipsemagazine.com/why-women-kill-premieres-on-august-15-on-cbs-all-access/why-women-kill-cast-red-carpet/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?fit=4032%2C3024" data-orig-size="4032,3024" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;1.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone 7&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1565204971&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;3.99&quot;,&quot;iso&quot;:&quot;25&quot;,&quot;shutter_speed&quot;:&quot;0.0083333333333333&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Why Women Kill cast red carpet" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?fit=400%2C300" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?fit=474%2C356" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?w=4032 4032w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?resize=400%2C300 400w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?resize=768%2C576 768w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?resize=1024%2C768 1024w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?w=948 948w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?w=1422 1422w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?fit=400%2C300&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/why-women-kill-premieres-on-august-15-on-cbs-all-access/">WHY WOMEN KILL premieres on August 15 on CBS All Access</a></h2>

					    <p>Three decades, three women, one house.  WHY WOMEN KILL is...</p>
	                		<a href="http://eclipsemagazine.com/why-women-kill-premieres-on-august-15-on-cbs-all-access/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
		</div>

					</div>
		</div>
		</aside><aside id="pfcwidget-8" class="widget pfc-widget">
		<div class="pfc-posts-wrap">

			<h1 class="widget-title">Movie Reviews</h1>
			<div class="pfc-posts-inner">

				
		<div class="pfc-posts-main">

			
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/call-of-the-wild-is-corny-as-heck-but-it-works/"><img width="474" height="199" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/THECALLOFTHEWILD_IMAGE2-e1582242972174.jpg?fit=474%2C199" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="92107" data-permalink="http://eclipsemagazine.com/call-of-the-wild-is-corny-as-heck-but-it-works/call-of-the-wild-2/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/THECALLOFTHEWILD_IMAGE2-e1582242972174.jpg?fit=1193%2C500" data-orig-size="1193,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Courtesy of Twentieth Century Fox&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1573489451&quot;,&quot;copyright&quot;:&quot;\u00a9 2019 Twentieth Century Fox Film Corporation. All rights reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;CALL OF THE WILD&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="CALL OF THE WILD" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/THECALLOFTHEWILD_IMAGE2-e1582242972174.jpg?fit=400%2C168" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/THECALLOFTHEWILD_IMAGE2-e1582242972174.jpg?fit=474%2C199" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/THECALLOFTHEWILD_IMAGE2-e1582242972174.jpg?w=1193 1193w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/THECALLOFTHEWILD_IMAGE2-e1582242972174.jpg?w=948 948w" data-lazy-sizes="(max-width: 474px) 100vw, 474px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/THECALLOFTHEWILD_IMAGE2-e1582242972174.jpg?fit=474%2C199&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/call-of-the-wild-is-corny-as-heck-but-it-works/">Call of the Wild Is Corny as Heck – But It Works!</a></h2>

					    					    	<span class="posted-date">February 20, 2020</span>
					    	<p>20th Century’s Call of the wild is the kind of family movie Disney used to...</p>
	                		<a href="http://eclipsemagazine.com/call-of-the-wild-is-corny-as-heck-but-it-works/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/birds-of-prey-less-whimsy-than-expected-but-still-a-lot-of-fun/"><img width="474" height="252" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?fit=474%2C252" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91966" data-permalink="http://eclipsemagazine.com/birds-of-prey-less-whimsy-than-expected-but-still-a-lot-of-fun/bop-group-shot-2/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?fit=575%2C306" data-orig-size="575,306" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BOP Group Shot" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?fit=400%2C213" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?fit=474%2C252" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?w=575 575w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?resize=400%2C213 400w" data-lazy-sizes="(max-width: 474px) 100vw, 474px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?fit=474%2C252&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/birds-of-prey-less-whimsy-than-expected-but-still-a-lot-of-fun/">Birds of Prey – Less Whimsy Than Expected but Still a Lot of Fun!</a></h2>

					    					    	<span class="posted-date">February 6, 2020</span>
					    	<p>Given the way that Margo Robbie’s nastily whimsical Harley Quinn was the lone standout in...</p>
	                		<a href="http://eclipsemagazine.com/birds-of-prey-less-whimsy-than-expected-but-still-a-lot-of-fun/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/dolittle-is-inspired-silliness/"><img width="474" height="255" src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/2499_FP_00272R-e1579236609823.jpg?fit=474%2C255" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91774" data-permalink="http://eclipsemagazine.com/dolittle-is-inspired-silliness/null-37/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/2499_FP_00272R-e1579236609823.jpg?fit=930%2C500" data-orig-size="930,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Photo Credit: Universal Pictures&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;(from left) Gorilla Chee-Chee (Rami Malek) and Dr. John Dolittle (Robert Downey Jr.) in \&quot;Dolittle,\&quot; directed by Stephen Gaghan.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;COPYRIGHT \u00a9 2020 UNIVERSAL STUDIOS and PERFECT UNIVERSE INVESTMENT INC. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;null&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="null" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/2499_FP_00272R-e1579236609823.jpg?fit=400%2C215" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/2499_FP_00272R-e1579236609823.jpg?fit=474%2C255" data-lazy-src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/2499_FP_00272R-e1579236609823.jpg?fit=474%2C255&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/dolittle-is-inspired-silliness/">Dolittle Is Inspired Silliness!</a></h2>

					    					    	<span class="posted-date">January 17, 2020</span>
					    	<p>The new non-musical remake of Dr. Dolittle, with the title shortened to simply Dolittle, is...</p>
	                		<a href="http://eclipsemagazine.com/dolittle-is-inspired-silliness/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/bad-boys-for-life-is-loud-fun/"><img width="474" height="315" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/DF-03930-e1579235816784.jpg?fit=474%2C315" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91769" data-permalink="http://eclipsemagazine.com/bad-boys-for-life-is-loud-fun/martin-lawrence-will-smith/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/DF-03930-e1579235816784.jpg?fit=752%2C500" data-orig-size="752,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Ben Rothstein&quot;,&quot;camera&quot;:&quot;ILCE-9&quot;,&quot;caption&quot;:&quot;Mike Lowrey (WILL SMITH), Marcus Burnett (MARTIN LAWRENCE) have each others backs in Columbia Pictures&#039; BAD BOYS FOR LIFE.&quot;,&quot;created_timestamp&quot;:&quot;1550180660&quot;,&quot;copyright&quot;:&quot;\u00a9 2019 CTMG, Inc. All Rights Reserved.  ALL IMAGES ARE PROPERTY OF SONY PICTURES ENTERTAINMENT INC. FOR PROMOTIONAL USE ONLY. S&quot;,&quot;focal_length&quot;:&quot;94&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.0025&quot;,&quot;title&quot;:&quot;Martin Lawrence, Will Smith,&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Martin Lawrence, Will Smith," data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/DF-03930-e1579235816784.jpg?fit=400%2C266" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/DF-03930-e1579235816784.jpg?fit=474%2C315" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/DF-03930-e1579235816784.jpg?fit=474%2C315&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/bad-boys-for-life-is-loud-fun/">Bad Boys for Life is Loud Fun!</a></h2>

					    					    	<span class="posted-date">January 17, 2020</span>
					    	<p>Thanks to co-directors Adil El Arbi and Bilall Fallah Bad Boys for Life is both...</p>
	                		<a href="http://eclipsemagazine.com/bad-boys-for-life-is-loud-fun/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/knives-out-rian-johnson-out-cozies-agatha-christie/"><img width="474" height="316" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/knives-out-KO_D10_03986_R_rgb-e1574971564881.jpg?fit=474%2C316" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91289" data-permalink="http://eclipsemagazine.com/knives-out-rian-johnson-out-cozies-agatha-christie/morning-bell-2/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/knives-out-KO_D10_03986_R_rgb-e1574971564881.jpg?fit=750%2C500" data-orig-size="750,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Claire Folger&quot;,&quot;camera&quot;:&quot;X-T2&quot;,&quot;caption&quot;:&quot;KO_03655.dng&quot;,&quot;created_timestamp&quot;:&quot;1541764202&quot;,&quot;copyright&quot;:&quot;\u00a9 2018 MRC II Distribution Company L.P. All rights reserved.&quot;,&quot;focal_length&quot;:&quot;94.5&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.00625&quot;,&quot;title&quot;:&quot;MORNING BELL&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="MORNING BELL" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/knives-out-KO_D10_03986_R_rgb-e1574971564881.jpg?fit=400%2C267" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/knives-out-KO_D10_03986_R_rgb-e1574971564881.jpg?fit=474%2C316" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/knives-out-KO_D10_03986_R_rgb-e1574971564881.jpg?fit=474%2C316&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/knives-out-rian-johnson-out-cozies-agatha-christie/">Knives Out: Rian Johnson Out Cozies Agatha Christie!</a></h2>

					    					    	<span class="posted-date">November 28, 2019</span>
					    	<p>Rian Johnson’s follow up to Star Wars: The Last Jedi finds him working new angles...</p>
	                		<a href="http://eclipsemagazine.com/knives-out-rian-johnson-out-cozies-agatha-christie/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/doctor-sleep-is-too-long-but-still-unsettling/"><img width="474" height="316" src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/rev-1-DS-04249r_High_Res_JPEG-e1573243316231.jpeg?fit=474%2C316" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91082" data-permalink="http://eclipsemagazine.com/doctor-sleep-is-too-long-but-still-unsettling/rev-1-ds-04249r_high_res_jpeg/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/rev-1-DS-04249r_High_Res_JPEG-e1573243316231.jpeg?fit=750%2C500" data-orig-size="750,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="rev-1-DS-04249r_High_Res_JPEG" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/rev-1-DS-04249r_High_Res_JPEG-e1573243316231.jpeg?fit=400%2C267" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/rev-1-DS-04249r_High_Res_JPEG-e1573243316231.jpeg?fit=474%2C316" data-lazy-src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/rev-1-DS-04249r_High_Res_JPEG-e1573243316231.jpeg?fit=474%2C316&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/doctor-sleep-is-too-long-but-still-unsettling/">Doctor Sleep is Too Long but Still Unsettling!</a></h2>

					    					    	<span class="posted-date">November 8, 2019</span>
					    	<p>Doctor Sleep follows the decades-older Danny Torrance (Ewan McGregor) – now going by just Dan...</p>
	                		<a href="http://eclipsemagazine.com/doctor-sleep-is-too-long-but-still-unsettling/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/terminator-dark-fate-not-that-bad-michelles-review-spoiler-free/"><img width="474" height="267" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?fit=474%2C267" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91037" data-permalink="http://eclipsemagazine.com/terminator-dark-fate-not-that-bad-michelles-review-spoiler-free/phoenix-9/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?fit=5020%2C2824" data-orig-size="5020,2824" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;Kerry Brown&quot;,&quot;camera&quot;:&quot;ILCE-9&quot;,&quot;caption&quot;:&quot;Linda Hamilton stars in Skydance Productions and Paramount Pictures&#039; \&quot;TERMINATOR: DARK FATE.\&quot;&quot;,&quot;created_timestamp&quot;:&quot;1531189722&quot;,&quot;copyright&quot;:&quot;\u00a9 2018 SKYDANCE PRODUCTIONS AND PARAMOUNT PICTURES. ALL RIGHTS RESERVED.&quot;,&quot;focal_length&quot;:&quot;171&quot;,&quot;iso&quot;:&quot;320&quot;,&quot;shutter_speed&quot;:&quot;0.002&quot;,&quot;title&quot;:&quot;PHOENIX&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="PHOENIX" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?fit=400%2C225" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?fit=474%2C267" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?w=5020 5020w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?resize=400%2C225 400w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?resize=768%2C432 768w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?resize=1024%2C576 1024w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?w=948 948w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?w=1422 1422w" data-lazy-sizes="(max-width: 474px) 100vw, 474px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?fit=474%2C267&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/terminator-dark-fate-not-that-bad-michelles-review-spoiler-free/">Terminator: Dark Fate, Not That Bad, Michelle&#8217;s Review Spoiler Free</a></h2>

					    					    	<span class="posted-date">November 3, 2019</span>
					    	<p>Terminator: Dark Fate wants to pretend like the last 4 or 5 sequels to T2,...</p>
	                		<a href="http://eclipsemagazine.com/terminator-dark-fate-not-that-bad-michelles-review-spoiler-free/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
		</div>

					</div>
		</div>
		</aside></div><!-- #content-sidebar -->
<div id="secondary">
		<h2 class="site-description">Entertainment News for The Rest of Us</h2>
	
	
		<div id="primary-sidebar" class="primary-sidebar widget-area" role="complementary">
		<aside id="pfcwidget-4" class="widget pfc-widget">
		<div class="pfc-posts-wrap">

			<h1 class="widget-title">Movie News</h1>
			<div class="pfc-posts-inner">

				
		<div class="pfc-posts-main">

			
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/coronavirus-changes-movie-dates/"><img width="400" height="225" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/a_quiet_place_part_2_-_publicity_still_-_2020_-e1584036013605.jpg?fit=400%2C225" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="92184" data-permalink="http://eclipsemagazine.com/coronavirus-changes-movie-dates/a-quiet-place-2-4/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/a_quiet_place_part_2_-_publicity_still_-_2020_-e1584036013605.jpg?fit=888%2C500" data-orig-size="888,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;11&quot;,&quot;credit&quot;:&quot;Photo Credit: Jonny Cournoyer&quot;,&quot;camera&quot;:&quot;ILCE-9&quot;,&quot;caption&quot;:&quot;Evelyn (Emily Blunt) and Marcus (Noah Jupe) brave the unknown in \&quot;A Quiet Place Part II.\u201d&quot;,&quot;created_timestamp&quot;:&quot;1564141053&quot;,&quot;copyright&quot;:&quot;\u00a9 2019 Paramount Pictures. All Rights Reserved&quot;,&quot;focal_length&quot;:&quot;120&quot;,&quot;iso&quot;:&quot;800&quot;,&quot;shutter_speed&quot;:&quot;0.004&quot;,&quot;title&quot;:&quot;A QUIET PLACE 2&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="A QUIET PLACE 2" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/a_quiet_place_part_2_-_publicity_still_-_2020_-e1584036013605.jpg?fit=400%2C225" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/a_quiet_place_part_2_-_publicity_still_-_2020_-e1584036013605.jpg?fit=474%2C267" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/a_quiet_place_part_2_-_publicity_still_-_2020_-e1584036013605.jpg?fit=400%2C225&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/coronavirus-changes-movie-dates/">Coronavirus Changes Movie Dates!</a></h2>

					    <p>The spread of the coronavirus has already caused the NBA...</p>
	                		<a href="http://eclipsemagazine.com/coronavirus-changes-movie-dates/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/thats-not-my-story-trailer-marvels-black-widow/"><img width="400" height="267" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Poster-Crop-e1583783740774.jpg?fit=400%2C267" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="92167" data-permalink="http://eclipsemagazine.com/thats-not-my-story-trailer-marvels-black-widow/poster-crop/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Poster-Crop-e1583783740774.jpg?fit=750%2C500" data-orig-size="750,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Poster Crop" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Poster-Crop-e1583783740774.jpg?fit=400%2C267" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Poster-Crop-e1583783740774.jpg?fit=474%2C316" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Poster-Crop-e1583783740774.jpg?fit=400%2C267&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/thats-not-my-story-trailer-marvels-black-widow/">That&#8217;s Not My Story Trailer: Marvel&#8217;s Black Widow!</a></h2>

					    <p>She's not running anymore. In the film's final trailer, Marvel's...</p>
	                		<a href="http://eclipsemagazine.com/thats-not-my-story-trailer-marvels-black-widow/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/save-your-father-and-save-the-world-trailer-artemis-fowl/"><img width="400" height="225" src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Artemis-Fowl-Banner.jpg?fit=400%2C225" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="92145" data-permalink="http://eclipsemagazine.com/save-your-father-and-save-the-world-trailer-artemis-fowl/artemis-fowl-banner/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Artemis-Fowl-Banner.jpg?fit=820%2C462" data-orig-size="820,462" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Artemis Fowl Banner" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Artemis-Fowl-Banner.jpg?fit=400%2C225" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Artemis-Fowl-Banner.jpg?fit=474%2C267" data-lazy-srcset="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Artemis-Fowl-Banner.jpg?w=820 820w, https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Artemis-Fowl-Banner.jpg?resize=400%2C225 400w, https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Artemis-Fowl-Banner.jpg?resize=768%2C433 768w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Artemis-Fowl-Banner.jpg?fit=400%2C225&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/save-your-father-and-save-the-world-trailer-artemis-fowl/">Save Your Father and Save the World Trailer: Artemis Fowl!</a></h2>

					    <p>The world's greatest criminal mastermind is about to save the...</p>
	                		<a href="http://eclipsemagazine.com/save-your-father-and-save-the-world-trailer-artemis-fowl/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/are-you-ready-to-rumble-trailer-rumble/"><img width="400" height="168" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/rumble-RMBL-FF-001_rgb-e1582747572236.jpg?fit=400%2C168" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="92127" data-permalink="http://eclipsemagazine.com/are-you-ready-to-rumble-trailer-rumble/rumble/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/rumble-RMBL-FF-001_rgb-e1582747572236.jpg?fit=1193%2C500" data-orig-size="1193,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Photo Credit: Paramount Animatio&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;Winnie (Geraldine Viswanathan) and Steve (Will Arnett) in RUMBLE from Paramount Animation. Photo Credit: Paramount Animation.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9 2020 Paramount Animation, a Division of Paramount Pictures. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;RUMBLE&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="RUMBLE" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/rumble-RMBL-FF-001_rgb-e1582747572236.jpg?fit=400%2C168" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/rumble-RMBL-FF-001_rgb-e1582747572236.jpg?fit=474%2C199" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/rumble-RMBL-FF-001_rgb-e1582747572236.jpg?w=1193 1193w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/rumble-RMBL-FF-001_rgb-e1582747572236.jpg?w=948 948w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/rumble-RMBL-FF-001_rgb-e1582747572236.jpg?fit=400%2C168&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/are-you-ready-to-rumble-trailer-rumble/">Are You Ready To Rumble? Trailer: RUMBLE!</a></h2>

					    <p>In a world where monster wrestling is a global sport...</p>
	                		<a href="http://eclipsemagazine.com/are-you-ready-to-rumble-trailer-rumble/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/mulan-director-and-stars-talk-stunts/"><img width="400" height="267" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Mulan_1200_R-e1575650140402.jpg?fit=400%2C267" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91375" data-permalink="http://eclipsemagazine.com/bring-honor-to-us-all-trailer-mulan/mulan_1200_r-2/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Mulan_1200_R-e1575650140402.jpg?fit=750%2C500" data-orig-size="750,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;9&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;Canon EOS 5D Mark IV&quot;,&quot;caption&quot;:&quot;Disney&#039;s MULAN\r\rMulan (Yifei Liu)\r\rPhoto: Stephen Tilley\r\r\u00a9 2018 Disney Enterprises, Inc. All Rights Reserved.&quot;,&quot;created_timestamp&quot;:&quot;1533208972&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;85&quot;,&quot;iso&quot;:&quot;250&quot;,&quot;shutter_speed&quot;:&quot;0.005&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Mulan_1200_R" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Mulan_1200_R-e1575650140402.jpg?fit=400%2C267" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Mulan_1200_R-e1575650140402.jpg?fit=474%2C316" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Mulan_1200_R-e1575650140402.jpg?fit=400%2C267&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/mulan-director-and-stars-talk-stunts/">Mulan Director and Stars Talk Stunts!</a></h2>

					    <p>Disney's Mulan is - judging by its trailers - one...</p>
	                		<a href="http://eclipsemagazine.com/mulan-director-and-stars-talk-stunts/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
		</div>

					</div>
		</div>
		</aside><aside id="pfcwidget-6" class="widget pfc-widget">
		<div class="pfc-posts-wrap">

			<h1 class="widget-title">Television News</h1>
			<div class="pfc-posts-inner">

				
		<div class="pfc-posts-main">

			
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/"><img width="672" height="372" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?resize=672%2C372" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="92187" data-permalink="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/frozen-2-6/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?fit=1194%2C500" data-orig-size="1194,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Walt Disney Animation Studios&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;From the Academy Award\u00ae-winning team\u2014directors Jennifer Lee and Chris Buck, and producer Peter Del Vecho\u2014and featuring the voices of Idina Menzel, Kristen Bell, Jonathan Groff and Josh Gad, and the music of Oscar\u00ae-winning songwriters Kristen Anderson-Lopez and Robert Lopez, Walt Disney Animation Studios\u2019 \u201cFrozen 2\u201d opens in U.S. theaters on Nov. 22, 2019. \r\r\u00a92019 Disney. All Rights Reserved.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a92019 Disney. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;FROZEN 2&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="FROZEN 2" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?fit=400%2C168" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?fit=474%2C199" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?zoom=2&amp;resize=672%2C372 1344w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?zoom=3&amp;resize=672%2C372 2016w" data-lazy-sizes="(max-width: 672px) 100vw, 672px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/03/Frozen2_PRINT-USE_trailer1_FINAL_CMYK-scaled-e1584157685519.jpg?resize=672%2C372&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/">Frozen 2 To Make Early Debut on Disney+!</a></h2>

					    					    	<span class="posted-date">March 13, 2020</span>
					    	<p>The Walt Disney Company has announced that Frozen 2 will...</p>
	                		<a href="http://eclipsemagazine.com/frozen-2-to-make-early-debut-on-disney/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/disney-resurrects-groundbreaking-animated-series-with-the-proud-family-louder-and-louder/"><img width="672" height="372" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Proud-Family_Concept-Art7-e1582831603380.jpeg?resize=672%2C372" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="92138" data-permalink="http://eclipsemagazine.com/disney-resurrects-groundbreaking-animated-series-with-the-proud-family-louder-and-louder/the-proud-family-louder-and-prouder/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Proud-Family_Concept-Art7-e1582831603380.jpeg?fit=706%2C500" data-orig-size="706,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Disney+&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;THE PROUD FAMILY: LOUDER AND PROUDER (Disney+)&quot;,&quot;created_timestamp&quot;:&quot;1572553946&quot;,&quot;copyright&quot;:&quot;\u00a9 2020 Disney Enterprises, Inc. All rights reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;THE PROUD FAMILY: LOUDER AND PROUDER&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="THE PROUD FAMILY: LOUDER AND PROUDER" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Proud-Family_Concept-Art7-e1582831603380.jpeg?fit=400%2C283" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Proud-Family_Concept-Art7-e1582831603380.jpeg?fit=474%2C336" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Proud-Family_Concept-Art7-e1582831603380.jpeg?zoom=2&amp;resize=672%2C372 1344w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Proud-Family_Concept-Art7-e1582831603380.jpeg?zoom=3&amp;resize=672%2C372 2016w" data-lazy-sizes="(max-width: 672px) 100vw, 672px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Proud-Family_Concept-Art7-e1582831603380.jpeg?resize=672%2C372&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/disney-resurrects-groundbreaking-animated-series-with-the-proud-family-louder-and-louder/">Disney+ Resurrects Groundbreaking Animated Series with The Proud Family: Louder and Louder!</a></h2>

					    					    	<span class="posted-date">February 27, 2020</span>
					    	<p>Eighteen years since Disney Channel premiered  The Proud Family, Disney+...</p>
	                		<a href="http://eclipsemagazine.com/disney-resurrects-groundbreaking-animated-series-with-the-proud-family-louder-and-louder/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
					<div class="news-text-wrap info-without-space">

					    <h2><a href="http://eclipsemagazine.com/if-you-set-your-mind-to-it-trailer-netflixs-the-letter-for-the-king/">If You Set Your Mind to It Trailer: Netflix&#8217;s The Letter for the King!</a></h2>

					    					    	<span class="posted-date">February 26, 2020</span>
					    	<p>When a ruthless prince threatens to cast the world into...</p>
	                		<a href="http://eclipsemagazine.com/if-you-set-your-mind-to-it-trailer-netflixs-the-letter-for-the-king/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/tony-hale-cast-in-dual-role-in-hulus-the-mysterious-benedict-society/"><img width="672" height="372" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/SJM-L-HALE-0130-011-e1582745129109.jpg?resize=672%2C372" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="92121" data-permalink="http://eclipsemagazine.com/tony-hale-cast-in-dual-role-in-hulus-the-mysterious-benedict-society/sjm-l-hale-0130-011/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/SJM-L-HALE-0130-011-e1582745129109.jpg?fit=760%2C500" data-orig-size="760,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SJM-L-HALE-0130-01[1]" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/SJM-L-HALE-0130-011-e1582745129109.jpg?fit=400%2C263" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/SJM-L-HALE-0130-011-e1582745129109.jpg?fit=474%2C312" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/SJM-L-HALE-0130-011-e1582745129109.jpg?zoom=2&amp;resize=672%2C372 1344w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/SJM-L-HALE-0130-011-e1582745129109.jpg?zoom=3&amp;resize=672%2C372 2016w" data-lazy-sizes="(max-width: 672px) 100vw, 672px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/SJM-L-HALE-0130-011-e1582745129109.jpg?resize=672%2C372&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/tony-hale-cast-in-dual-role-in-hulus-the-mysterious-benedict-society/">Tony Hale Cast In Dual Role in Hulu&#8217;s The Mysterious Benedict Society!</a></h2>

					    					    	<span class="posted-date">February 26, 2020</span>
					    	<p>Tony Hale has been cast in the dual role of...</p>
	                		<a href="http://eclipsemagazine.com/tony-hale-cast-in-dual-role-in-hulus-the-mysterious-benedict-society/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/brain-busting-competition-series-mental-samurai-renewed-by-fox/"><img width="500" height="372" src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/01/Mental-Samurai.png?resize=500%2C372" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="88087" data-permalink="http://eclipsemagazine.com/fox-sets-premiere-date-for-mental-samurai/mental-samurai-2/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/01/Mental-Samurai.png?fit=500%2C500" data-orig-size="500,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Mental Samurai" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/01/Mental-Samurai.png?fit=400%2C400" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/01/Mental-Samurai.png?fit=474%2C474" data-lazy-src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/01/Mental-Samurai.png?resize=500%2C372&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/brain-busting-competition-series-mental-samurai-renewed-by-fox/">Brain-Busting Competition Series Mental Samurai Renewed by FOX!</a></h2>

					    					    	<span class="posted-date">February 25, 2020</span>
					    	<p>The Rob Lowe-hosted competition series Mental Samurai has been renewed...</p>
	                		<a href="http://eclipsemagazine.com/brain-busting-competition-series-mental-samurai-renewed-by-fox/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
		</div>

					</div>
		</div>
		</aside>	</div><!-- #primary-sidebar -->
	</div><!-- #secondary -->

		</div><!-- #main -->

		<footer id="colophon" class="site-footer" role="contentinfo">

			
			<div class="site-info">
												<a href="https://wordpress.org/" class="imprint">
					Proudly powered by WordPress				</a>
			</div><!-- .site-info -->
		</footer><!-- #colophon -->
	</div><!-- #page -->

		<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/eclipsemagazine.com\/frozen-2-to-make-early-debut-on-disney\/":92186};
	</script>
				<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
								<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
		<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Maraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='http://eclipsemagazine.com/wp-content/themes/twentyfourteen/js/functions.js?ver=20150315'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/postmessage.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/jquery.jetpack-resize.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/likes/queuehandler.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202011#ver=202011' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-202011.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.1.1',blog:'2511119',post:'92186',tz:'-4',srv:'eclipsemagazine.com'} ]);
	_stq.push([ 'clickTrackerInit', '2511119', '92186' ]);
</script>
</body>
</html>
