<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<title>(Not) Free at Last Trailer: The Invisible Man! | EclipseMagazine</title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://eclipsemagazine.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="http://eclipsemagazine.com/wp-content/themes/twentyfourteen/js/html5.js"></script>
	<![endif]-->
	<script type='text/javascript'>function ctSetCookie(c_name, value, def_value){document.cookie = c_name + '=' + escape(value) + '; path=/';}ctSetCookie('ct_checkjs', '2009540506', '0');</script><link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="EclipseMagazine &raquo; Feed" href="http://eclipsemagazine.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="EclipseMagazine &raquo; Comments Feed" href="http://eclipsemagazine.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="EclipseMagazine &raquo; (Not) Free at Last Trailer: The Invisible Man! Comments Feed" href="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/eclipsemagazine.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='twentyfourteen-jetpack-css'  href='https://c0.wp.com/p/jetpack/8.1.1/modules/theme-tools/compat/twentyfourteen.css' type='text/css' media='all' />
<!-- `jetpack_related-posts` is included in the concatenated jetpack.css -->
<link rel='stylesheet' id='pfc-style-css'  href='http://eclipsemagazine.com/wp-content/plugins/posts-from-category/assets/pfc-style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/theme.min.css' type='text/css' media='all' />
<!-- `jetpack_likes` is included in the concatenated jetpack.css -->
<link rel='stylesheet' id='twentyfourteen-lato-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900%2C300italic%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='https://c0.wp.com/p/jetpack/8.1.1/_inc/genericons/genericons/genericons.css' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfourteen-style-css'  href='http://eclipsemagazine.com/wp-content/themes/twentyfourteen/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfourteen-block-style-css'  href='http://eclipsemagazine.com/wp-content/themes/twentyfourteen/css/blocks.css?ver=20181230' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfourteen-ie-css'  href='http://eclipsemagazine.com/wp-content/themes/twentyfourteen/css/ie.css?ver=20131205' type='text/css' media='all' />
<![endif]-->
<!-- `sharedaddy` is included in the concatenated jetpack.css -->
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.1.1/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.1.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/related-posts/related-posts.min.js'></script>
<script type='text/javascript' src='http://eclipsemagazine.com/wp-content/plugins/posts-from-category/assets/pfc-custom.js?ver=4.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctPublic = {"_ajax_nonce":"d6383c20c9","_ajax_url":"http:\/\/eclipsemagazine.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://eclipsemagazine.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js?ver=5.133.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctNocache = {"ajaxurl":"http:\/\/eclipsemagazine.com\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"","blog_home":"http:\/\/eclipsemagazine.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://eclipsemagazine.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_nocache.min.js?ver=5.133.1'></script>
<link rel='https://api.w.org/' href='http://eclipsemagazine.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://eclipsemagazine.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://eclipsemagazine.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Birds of Prey – Less Whimsy Than Expected but Still a Lot of Fun!' href='http://eclipsemagazine.com/birds-of-prey-less-whimsy-than-expected-but-still-a-lot-of-fun/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/" />
<link rel='shortlink' href='https://wp.me/paxfV-nVC' />
<link rel="alternate" type="application/json+oembed" href="http://eclipsemagazine.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Feclipsemagazine.com%2Fnot-free-at-last-trailer-the-invisible-man%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://eclipsemagazine.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Feclipsemagazine.com%2Fnot-free-at-last-trailer-the-invisible-man%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>		<style type="text/css" id="twentyfourteen-header-css">
				.site-title,
		.site-description {
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
			position: absolute;
		}
				</style>
		<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #550000; background-image: url("http://eclipsemagazine.com/wp-content/uploads/2014/05/bg_body.png"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: fixed; }
</style>
				<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="(Not) Free at Last Trailer: The Invisible Man!" />
<meta property="og:url" content="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/" />
<meta property="og:description" content="Five days later, there&#8217;s a new, even creepier, trailer for Universal Pictures/Blumhouse Productions&#8217; The Invisible Man. The Invisible Man opens on February 28th." />
<meta property="article:published_time" content="2020-02-08T00:45:33+00:00" />
<meta property="article:modified_time" content="2020-02-08T00:45:33+00:00" />
<meta property="og:site_name" content="EclipseMagazine" />
<meta property="og:image" content="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?fit=1192%2C500" />
<meta property="og:image:width" content="1192" />
<meta property="og:image:height" content="500" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@EclipseMagazine" />
<meta name="twitter:text:title" content="(Not) Free at Last Trailer: The Invisible Man!" />
<meta name="twitter:image" content="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?fit=1192%2C500&#038;w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
</head>

<body class="post-template-default single single-post postid-91984 single-format-standard custom-background wp-embed-responsive group-blog header-image singular">
<div id="page" class="hfeed site">
		<div id="site-header">
		<a href="http://eclipsemagazine.com/" rel="home">
			<img src="http://eclipsemagazine.com/wp-content/uploads/2014/05/cropped-eclipse-header.jpg" width="1260" height="240" alt="EclipseMagazine">
		</a>
	</div>
	
	<header id="masthead" class="site-header" role="banner">
		<div class="header-main">
			<h1 class="site-title"><a href="http://eclipsemagazine.com/" rel="home">EclipseMagazine</a></h1>

			<div class="search-toggle">
				<a href="#search-container" class="screen-reader-text" aria-expanded="false" aria-controls="search-container">Search</a>
			</div>

			<nav id="primary-navigation" class="site-navigation primary-navigation" role="navigation">
				<button class="menu-toggle">Primary Menu</button>
				<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
				<div class="menu-header-menu-container"><ul id="primary-menu" class="nav-menu"><li id="menu-item-47078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47078"><a href="http://eclipsemagazine.com/category/geekscholars/">GeekScholars</a></li>
<li id="menu-item-47079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47079"><a href="http://eclipsemagazine.com/category/hollywood-insider/">Hollywood Insider</a></li>
<li id="menu-item-47080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47080"><a href="http://eclipsemagazine.com/category/movienews/">Movie News</a></li>
<li id="menu-item-47081" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47081"><a href="http://eclipsemagazine.com/category/movie-reviews/">Movie Reviews</a></li>
<li id="menu-item-47082" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47082"><a href="http://eclipsemagazine.com/category/movie-trailers/">Movie Trailers</a></li>
<li id="menu-item-47083" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47083"><a href="http://eclipsemagazine.com/category/out-and-about/">Out and About</a></li>
<li id="menu-item-47084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47084"><a href="http://eclipsemagazine.com/category/television/">Television</a></li>
<li id="menu-item-47085" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47085"><a href="http://eclipsemagazine.com/category/tv-reviews/">TV Reviews</a></li>
<li id="menu-item-47086" class="subscribelink menu-item menu-item-type-custom menu-item-object-custom menu-item-47086"><a href="http://eclipsemagazine.com/feed">Subscribe</a></li>
</ul></div>			</nav>
		</div>

		<div id="search-container" class="search-box-wrapper hide">
			<div class="search-box">
				<form role="search" method="get" class="search-form" action="http://eclipsemagazine.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</div>
		</div>
	</header><!-- #masthead -->

	<div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">
			
<article id="post-91984" class="post-91984 post type-post status-publish format-standard has-post-thumbnail hentry category-Movies tag-blumhouse-productions tag-elisabeth-moss tag-movie-trailers tag-the-invisible-man tag-universal-pictures">
	
		<div class="post-thumbnail">
			<img width="672" height="372" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?resize=672%2C372" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91885" data-permalink="http://eclipsemagazine.com/the-ultimate-stalker-trailer-the-invisible-man/the-invisible-man-2/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?fit=1192%2C500" data-orig-size="1192,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Universal Pictures&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9 2020 Universal Pictures&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;THE INVISIBLE MAN&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="THE INVISIBLE MAN" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?fit=400%2C168" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?fit=474%2C199" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?zoom=2&amp;resize=672%2C372 1344w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?zoom=3&amp;resize=672%2C372 2016w" data-lazy-sizes="(max-width: 672px) 100vw, 672px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?resize=672%2C372&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />		</div>

		
	<header class="entry-header">
				<div class="entry-meta">
			<span class="cat-links"><a href="http://eclipsemagazine.com/category/Movies/" rel="category tag">Movies</a></span>
		</div>
			<h1 class="entry-title">(Not) Free at Last Trailer: The Invisible Man!</h1>
		<div class="entry-meta">
			<span class="entry-date"><a href="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/" rel="bookmark"><time class="entry-date" datetime="2020-02-07T20:45:33-04:00">February 7, 2020</time></a></span> <span class="byline"><span class="author vcard"><a class="url fn n" href="http://eclipsemagazine.com/author/swiebe5/" rel="author">Sheldon Wiebe</a></span></span>			<span class="comments-link"><a href="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/#respond">Leave a comment</a></span>
						</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

		<div class="entry-content">
		<p>Five days later, there&#8217;s a new, even creepier, trailer for Universal Pictures/Blumhouse Productions&#8217; The Invisible Man.</p>
<p>The Invisible Man opens on February 28th.</p>
<p><span id="more-91984"></span></p>
<p><img data-attachment-id="91985" data-permalink="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/inv_teaser1sheet_rgb_5sm/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/INV_Teaser1Sheet_RGB_5SM-e1581122677614.jpg?fit=500%2C792" data-orig-size="500,792" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="INV_Teaser1Sheet_RGB_5SM" data-image-description data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/INV_Teaser1Sheet_RGB_5SM-e1581122677614.jpg?fit=253%2C400" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/INV_Teaser1Sheet_RGB_5SM-e1581122677614.jpg?fit=474%2C750" class="alignnone size-medium wp-image-91985 jetpack-lazy-image" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/INV_Teaser1Sheet_RGB_5SM.jpg?resize=253%2C400" alt width="253" height="400" data-recalc-dims="1" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/INV_Teaser1Sheet_RGB_5SM.jpg?resize=253%2C400&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img data-attachment-id="91985" data-permalink="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/inv_teaser1sheet_rgb_5sm/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/INV_Teaser1Sheet_RGB_5SM-e1581122677614.jpg?fit=500%2C792" data-orig-size="500,792" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="INV_Teaser1Sheet_RGB_5SM" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/INV_Teaser1Sheet_RGB_5SM-e1581122677614.jpg?fit=253%2C400" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/INV_Teaser1Sheet_RGB_5SM-e1581122677614.jpg?fit=474%2C750" class="alignnone size-medium wp-image-91985" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/INV_Teaser1Sheet_RGB_5SM.jpg?resize=253%2C400" alt="" width="253" height="400" data-recalc-dims="1" /></noscript></p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='474' height='267' src='https://www.youtube.com/embed/WO_FJdiY9dA?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p><span class="style-scope yt-formatted-string" dir="auto">The Invisible Man In Theaters February 28 </span><a class="yt-simple-endpoint style-scope yt-formatted-string" dir="auto" spellcheck="false" href="https://www.theinvisiblemanmovie.com/" target="_blank" rel="nofollow noopener noreferrer">https://www.TheInvisibleManMovie.com</a></p>
<p><span class="style-scope yt-formatted-string" dir="auto">What you can’t see can hurt you. </span></p>
<p><span class="style-scope yt-formatted-string" dir="auto">Emmy winner Elisabeth Moss (Us, Hulu’s The Handmaid’s Tale) stars in a terrifying modern tale of obsession inspired by Universal’s classic monster character. </span></p>
<p><span class="style-scope yt-formatted-string" dir="auto">Trapped in a violent, controlling relationship with a wealthy and brilliant scientist, Cecilia Kass (Moss) escapes in the dead of night and disappears into hiding, aided by her sister (Harriet Dyer, NBC’s The InBetween), their childhood friend (Aldis Hodge, Straight Outta Compton) and his teenage daughter (Storm Reid, HBO’s Euphoria). </span></p>
<p><span class="style-scope yt-formatted-string" dir="auto">But when Cecilia’s abusive ex (Oliver Jackson-Cohen, Netflix’s The Haunting of Hill House) commits suicide and leaves her a generous portion of his vast fortune, Cecilia suspects his death was a hoax. As a series of eerie coincidences turns lethal, threatening the lives of those she loves, Cecilia’s sanity begins to unravel as she desperately tries to prove that she is being hunted by someone nobody can see. </span></p>
<p><span class="style-scope yt-formatted-string" dir="auto">Jason Blum, our current-day master of the horror genre, produces The Invisible Man for his Blumhouse Productions. The Invisible Man is written, directed and executive produced by Leigh Whannell, one of the original conceivers of the Saw franchise who most recently directed Upgrade and Insidious: Chapter 3. </span></p>
<p><span class="style-scope yt-formatted-string" dir="auto">The film is also produced by Kylie du Fresne (Upgrade, The Sapphires) for Goalpost Pictures. The executive producers are Whannell, Beatriz Sequeira, Charles Layton, Rosemary Blight, Ben Grant, Couper Samuelson and Jeanette Volturno. The Invisible Man is a co-production of Goalpost Pictures Australia and Blumhouse Productions, in association with Nervous Tick, for Universal Pictures.</span></p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Sharing is Caring:</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/" data-text="(Not) Free at Last Trailer: The Invisible Man!" data-via="EclipseMagazine" >Tweet</a></li><li class="share-reddit"><div class="reddit_button"><iframe src="http://www.reddit.com/static/button/button1.html?newwindow=true&width=120&amp;url=http%3A%2F%2Feclipsemagazine.com%2Fnot-free-at-last-trailer-the-invisible-man%2F&amp;title=%28Not%29%20Free%20at%20Last%20Trailer%3A%20The%20Invisible%20Man%21" height="22" width="120" scrolling="no" frameborder="0"></iframe></div></li><li class="share-pinterest"><div class="pinterest_button"><a href="https://www.pinterest.com/pin/create/button/?url=http%3A%2F%2Feclipsemagazine.com%2Fnot-free-at-last-trailer-the-invisible-man%2F&#038;media=https%3A%2F%2Fi2.wp.com%2Feclipsemagazine.com%2Fwp-content%2Fuploads%2F2020%2F02%2F2527_T1F_0001-e1580694140672.jpg%3Ffit%3D1192%252C500&#038;description=%28Not%29%20Free%20at%20Last%20Trailer%3A%20The%20Invisible%20Man%21" data-pin-do="buttonPin" data-pin-config="beside"><img src="https://i2.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?w=474" data-recalc-dims="1" data-lazy-src="https://i2.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?w=474&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://i2.wp.com/assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png?w=474" data-recalc-dims="1" /></noscript></a></div></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-2511119-91984-5e3e053bf32a7' data-src='https://widgets.wp.com/likes/#blog_id=2511119&amp;post_id=91984&amp;origin=eclipsemagazine.com&amp;obj_id=2511119-91984-5e3e053bf32a7' data-name='like-post-frame-2511119-91984-5e3e053bf32a7'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div>	</div><!-- .entry-content -->
	
	<footer class="entry-meta"><span class="tag-links"><a href="http://eclipsemagazine.com/tag/blumhouse-productions/" rel="tag">Blumhouse Productions</a><a href="http://eclipsemagazine.com/tag/elisabeth-moss/" rel="tag">Elisabeth Moss</a><a href="http://eclipsemagazine.com/tag/movie-trailers/" rel="tag">Movie Trailers</a><a href="http://eclipsemagazine.com/tag/the-invisible-man/" rel="tag">The Invisible Man</a><a href="http://eclipsemagazine.com/tag/universal-pictures/" rel="tag">Universal Pictures</a></span></footer></article><!-- #post-## -->
		<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">
			<a href="http://eclipsemagazine.com/birds-of-prey-less-whimsy-than-expected-but-still-a-lot-of-fun/" rel="prev"><span class="meta-nav">Previous Post</span>Birds of Prey – Less Whimsy Than Expected but Still a Lot of Fun!</a>			</div><!-- .nav-links -->
		</nav><!-- .navigation -->
		
<div id="comments" class="comments-area">

	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/not-free-at-last-trailer-the-invisible-man/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://eclipsemagazine.com/wp-login.php?redirect_to=http%3A%2F%2Feclipsemagazine.com%2Fnot-free-at-last-trailer-the-invisible-man%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</div><!-- #comments -->
		</div><!-- #content -->
	</div><!-- #primary -->

<div id="content-sidebar" class="content-sidebar widget-area" role="complementary">
	<aside id="pfcwidget-9" class="widget pfc-widget">
		<div class="pfc-posts-wrap">

			<h1 class="widget-title">Hollywood Insider</h1>
			<div class="pfc-posts-inner">

				
		<div class="pfc-posts-main">

			
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/marlon-west-beyond-the-effects-of-frozen/"><img width="390" height="400" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?fit=390%2C400" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91267" data-permalink="http://eclipsemagazine.com/marlon-west-beyond-the-effects-of-frozen/marlon-3/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?fit=600%2C615" data-orig-size="600,615" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="marlon 3" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?fit=390%2C400" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?fit=474%2C486" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?w=600 600w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?resize=390%2C400 390w" data-lazy-sizes="(max-width: 390px) 100vw, 390px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/marlon-3.jpg?fit=390%2C400&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/marlon-west-beyond-the-effects-of-frozen/">Marlon West: Beyond the Effects of Frozen</a></h2>

					    <p>I have recently sat down with Marlon West, who is...</p>
	                		<a href="http://eclipsemagazine.com/marlon-west-beyond-the-effects-of-frozen/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/for-all-mankind-interviews-part-1/"><img width="400" height="225" src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?fit=400%2C225" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91028" data-permalink="http://eclipsemagazine.com/for-all-mankind-interviews-part-1/mv5bmjqyzwm2zgqtoguyzs00zty2ltk1odktyjzlnjdinmezzda0xkeyxkfqcgdeqxvynte1njy5mg-_v1_/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?fit=816%2C459" data-orig-size="816,459" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?fit=400%2C225" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?fit=474%2C267" data-lazy-srcset="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?w=816 816w, https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?resize=400%2C225 400w, https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?resize=768%2C432 768w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/MV5BMjQyZWM2ZGQtOGUyZS00ZTY2LTk1ODktYjZlNjdiNmEzZDA0XkEyXkFqcGdeQXVyNTE1NjY5Mg@@._V1_.jpg?fit=400%2C225&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/for-all-mankind-interviews-part-1/">For All Mankind Interviews Part 1</a></h2>

					    <p>Apple TV+ makes its debuts today in streaming media. One...</p>
	                		<a href="http://eclipsemagazine.com/for-all-mankind-interviews-part-1/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/terrence-blanchard-delivers-an-inspiring-score-to-a-maryland-legend/"><img width="400" height="320" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?fit=400%2C320" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91024" data-permalink="http://eclipsemagazine.com/terrence-blanchard-delivers-an-inspiring-score-to-a-maryland-legend/dsc_0485/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?fit=3170%2C2536" data-orig-size="3170,2536" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;6&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;NIKON D5000&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1571573401&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;140&quot;,&quot;iso&quot;:&quot;6400&quot;,&quot;shutter_speed&quot;:&quot;0.125&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Blanchard1" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?fit=400%2C320" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?fit=474%2C379" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?w=3170 3170w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?resize=400%2C320 400w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?resize=768%2C614 768w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?resize=1024%2C819 1024w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?w=948 948w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?w=1422 1422w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/DSC_0485.jpg?fit=400%2C320&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/terrence-blanchard-delivers-an-inspiring-score-to-a-maryland-legend/">Terrence Blanchard: Delivers an Inspiring Score to A Maryland Legend</a></h2>

					    <p>&nbsp; Film Composer Terence Blanchard is gearing up to bring...</p>
	                		<a href="http://eclipsemagazine.com/terrence-blanchard-delivers-an-inspiring-score-to-a-maryland-legend/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/cws-all-american-hunter-clowdus-talks-to-michelle/"><img width="400" height="238" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?fit=400%2C238" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="90828" data-permalink="http://eclipsemagazine.com/cws-all-american-hunter-clowdus-talks-to-michelle/cws-hunter-clowdus-wide/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?fit=624%2C371" data-orig-size="624,371" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="CWs Hunter Clowdus Wide" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?fit=400%2C238" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?fit=474%2C282" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?w=624 624w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?resize=400%2C238 400w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/10/CWs-Hunter-Clowdus-Wide.png?fit=400%2C238&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/cws-all-american-hunter-clowdus-talks-to-michelle/">CW&#8217;s All American Hunter Clowdus Talks To Michelle!</a></h2>

					    <p>I recently did an email interview with Hunter Clowdus, one...</p>
	                		<a href="http://eclipsemagazine.com/cws-all-american-hunter-clowdus-talks-to-michelle/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/john-travolta-from-being-a-fan-to-playing-a-fanatic/"><img width="400" height="300" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?fit=400%2C300" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="90341" data-permalink="http://eclipsemagazine.com/john-travolta-from-being-a-fan-to-playing-a-fanatic/v1-bjsymzewmtiwo2o7mtgymdy7mtiwmdsymja1oze2ntq/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?fit=1152%2C864" data-orig-size="1152,864" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?fit=400%2C300" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?fit=474%2C356" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?w=1152 1152w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?resize=400%2C300 400w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?resize=768%2C576 768w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?resize=1024%2C768 1024w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?w=948 948w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/v1.bjsyMzEwMTIwO2o7MTgyMDY7MTIwMDsyMjA1OzE2NTQ.jpeg?fit=400%2C300&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/john-travolta-from-being-a-fan-to-playing-a-fanatic/">John Travolta: From Being a Fan to playing a Fanatic</a></h2>

					    <p>On this edition of the INTERVUE, legendary actor John Travolta...</p>
	                		<a href="http://eclipsemagazine.com/john-travolta-from-being-a-fan-to-playing-a-fanatic/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/giancarlo-esposito-talks-about-mandalorian-with-michelle/"><img width="400" height="225" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?fit=400%2C225" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="90336" data-permalink="http://eclipsemagazine.com/giancarlo-esposito-talks-about-mandalorian-with-michelle/giancarlo-esposito-mandaloria-2/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?fit=700%2C394" data-orig-size="700,394" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Giancarlo Esposito Mandaloria 2" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?fit=400%2C225" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?fit=474%2C267" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?w=700 700w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?resize=400%2C225 400w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Giancarlo-Esposito-Mandaloria-2.png?fit=400%2C225&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/giancarlo-esposito-talks-about-mandalorian-with-michelle/">Giancarlo Esposito Talks About Mandalorian with Michelle!</a></h2>

					    <p>One of the biggest surprises last month was the discovery...</p>
	                		<a href="http://eclipsemagazine.com/giancarlo-esposito-talks-about-mandalorian-with-michelle/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/why-women-kill-premieres-on-august-15-on-cbs-all-access/"><img width="400" height="300" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?fit=400%2C300" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="90224" data-permalink="http://eclipsemagazine.com/why-women-kill-premieres-on-august-15-on-cbs-all-access/why-women-kill-cast-red-carpet/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?fit=4032%2C3024" data-orig-size="4032,3024" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;1.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone 7&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1565204971&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;3.99&quot;,&quot;iso&quot;:&quot;25&quot;,&quot;shutter_speed&quot;:&quot;0.0083333333333333&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Why Women Kill cast red carpet" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?fit=400%2C300" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?fit=474%2C356" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?w=4032 4032w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?resize=400%2C300 400w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?resize=768%2C576 768w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?resize=1024%2C768 1024w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?w=948 948w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?w=1422 1422w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/08/Why-Women-Kill-cast-red-carpet.jpg?fit=400%2C300&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/why-women-kill-premieres-on-august-15-on-cbs-all-access/">WHY WOMEN KILL premieres on August 15 on CBS All Access</a></h2>

					    <p>Three decades, three women, one house.  WHY WOMEN KILL is...</p>
	                		<a href="http://eclipsemagazine.com/why-women-kill-premieres-on-august-15-on-cbs-all-access/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
		</div>

					</div>
		</div>
		</aside><aside id="pfcwidget-8" class="widget pfc-widget">
		<div class="pfc-posts-wrap">

			<h1 class="widget-title">Movie Reviews</h1>
			<div class="pfc-posts-inner">

				
		<div class="pfc-posts-main">

			
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/birds-of-prey-less-whimsy-than-expected-but-still-a-lot-of-fun/"><img width="474" height="252" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?fit=474%2C252" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91966" data-permalink="http://eclipsemagazine.com/birds-of-prey-less-whimsy-than-expected-but-still-a-lot-of-fun/bop-group-shot-2/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?fit=575%2C306" data-orig-size="575,306" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BOP Group Shot" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?fit=400%2C213" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?fit=474%2C252" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?w=575 575w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?resize=400%2C213 400w" data-lazy-sizes="(max-width: 474px) 100vw, 474px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/BOP-Group-Shot.jpg?fit=474%2C252&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/birds-of-prey-less-whimsy-than-expected-but-still-a-lot-of-fun/">Birds of Prey – Less Whimsy Than Expected but Still a Lot of Fun!</a></h2>

					    					    	<span class="posted-date">February 6, 2020</span>
					    	<p>Given the way that Margo Robbie’s nastily whimsical Harley Quinn was the lone standout in...</p>
	                		<a href="http://eclipsemagazine.com/birds-of-prey-less-whimsy-than-expected-but-still-a-lot-of-fun/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/dolittle-is-inspired-silliness/"><img width="474" height="255" src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/2499_FP_00272R-e1579236609823.jpg?fit=474%2C255" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91774" data-permalink="http://eclipsemagazine.com/dolittle-is-inspired-silliness/null-37/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/2499_FP_00272R-e1579236609823.jpg?fit=930%2C500" data-orig-size="930,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Photo Credit: Universal Pictures&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;(from left) Gorilla Chee-Chee (Rami Malek) and Dr. John Dolittle (Robert Downey Jr.) in \&quot;Dolittle,\&quot; directed by Stephen Gaghan.&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;COPYRIGHT \u00a9 2020 UNIVERSAL STUDIOS and PERFECT UNIVERSE INVESTMENT INC. All Rights Reserved.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;null&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="null" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/2499_FP_00272R-e1579236609823.jpg?fit=400%2C215" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/2499_FP_00272R-e1579236609823.jpg?fit=474%2C255" data-lazy-src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/2499_FP_00272R-e1579236609823.jpg?fit=474%2C255&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/dolittle-is-inspired-silliness/">Dolittle Is Inspired Silliness!</a></h2>

					    					    	<span class="posted-date">January 17, 2020</span>
					    	<p>The new non-musical remake of Dr. Dolittle, with the title shortened to simply Dolittle, is...</p>
	                		<a href="http://eclipsemagazine.com/dolittle-is-inspired-silliness/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/bad-boys-for-life-is-loud-fun/"><img width="474" height="315" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/DF-03930-e1579235816784.jpg?fit=474%2C315" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91769" data-permalink="http://eclipsemagazine.com/bad-boys-for-life-is-loud-fun/martin-lawrence-will-smith/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/DF-03930-e1579235816784.jpg?fit=752%2C500" data-orig-size="752,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;2.8&quot;,&quot;credit&quot;:&quot;Ben Rothstein&quot;,&quot;camera&quot;:&quot;ILCE-9&quot;,&quot;caption&quot;:&quot;Mike Lowrey (WILL SMITH), Marcus Burnett (MARTIN LAWRENCE) have each others backs in Columbia Pictures&#039; BAD BOYS FOR LIFE.&quot;,&quot;created_timestamp&quot;:&quot;1550180660&quot;,&quot;copyright&quot;:&quot;\u00a9 2019 CTMG, Inc. All Rights Reserved.  ALL IMAGES ARE PROPERTY OF SONY PICTURES ENTERTAINMENT INC. FOR PROMOTIONAL USE ONLY. S&quot;,&quot;focal_length&quot;:&quot;94&quot;,&quot;iso&quot;:&quot;3200&quot;,&quot;shutter_speed&quot;:&quot;0.0025&quot;,&quot;title&quot;:&quot;Martin Lawrence, Will Smith,&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Martin Lawrence, Will Smith," data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/DF-03930-e1579235816784.jpg?fit=400%2C266" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/DF-03930-e1579235816784.jpg?fit=474%2C315" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/01/DF-03930-e1579235816784.jpg?fit=474%2C315&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/bad-boys-for-life-is-loud-fun/">Bad Boys for Life is Loud Fun!</a></h2>

					    					    	<span class="posted-date">January 17, 2020</span>
					    	<p>Thanks to co-directors Adil El Arbi and Bilall Fallah Bad Boys for Life is both...</p>
	                		<a href="http://eclipsemagazine.com/bad-boys-for-life-is-loud-fun/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/knives-out-rian-johnson-out-cozies-agatha-christie/"><img width="474" height="316" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/knives-out-KO_D10_03986_R_rgb-e1574971564881.jpg?fit=474%2C316" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91289" data-permalink="http://eclipsemagazine.com/knives-out-rian-johnson-out-cozies-agatha-christie/morning-bell-2/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/knives-out-KO_D10_03986_R_rgb-e1574971564881.jpg?fit=750%2C500" data-orig-size="750,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;4&quot;,&quot;credit&quot;:&quot;Claire Folger&quot;,&quot;camera&quot;:&quot;X-T2&quot;,&quot;caption&quot;:&quot;KO_03655.dng&quot;,&quot;created_timestamp&quot;:&quot;1541764202&quot;,&quot;copyright&quot;:&quot;\u00a9 2018 MRC II Distribution Company L.P. All rights reserved.&quot;,&quot;focal_length&quot;:&quot;94.5&quot;,&quot;iso&quot;:&quot;5000&quot;,&quot;shutter_speed&quot;:&quot;0.00625&quot;,&quot;title&quot;:&quot;MORNING BELL&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="MORNING BELL" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/knives-out-KO_D10_03986_R_rgb-e1574971564881.jpg?fit=400%2C267" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/knives-out-KO_D10_03986_R_rgb-e1574971564881.jpg?fit=474%2C316" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/knives-out-KO_D10_03986_R_rgb-e1574971564881.jpg?fit=474%2C316&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/knives-out-rian-johnson-out-cozies-agatha-christie/">Knives Out: Rian Johnson Out Cozies Agatha Christie!</a></h2>

					    					    	<span class="posted-date">November 28, 2019</span>
					    	<p>Rian Johnson’s follow up to Star Wars: The Last Jedi finds him working new angles...</p>
	                		<a href="http://eclipsemagazine.com/knives-out-rian-johnson-out-cozies-agatha-christie/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/doctor-sleep-is-too-long-but-still-unsettling/"><img width="474" height="316" src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/rev-1-DS-04249r_High_Res_JPEG-e1573243316231.jpeg?fit=474%2C316" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91082" data-permalink="http://eclipsemagazine.com/doctor-sleep-is-too-long-but-still-unsettling/rev-1-ds-04249r_high_res_jpeg/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/rev-1-DS-04249r_High_Res_JPEG-e1573243316231.jpeg?fit=750%2C500" data-orig-size="750,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="rev-1-DS-04249r_High_Res_JPEG" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/rev-1-DS-04249r_High_Res_JPEG-e1573243316231.jpeg?fit=400%2C267" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/rev-1-DS-04249r_High_Res_JPEG-e1573243316231.jpeg?fit=474%2C316" data-lazy-src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/rev-1-DS-04249r_High_Res_JPEG-e1573243316231.jpeg?fit=474%2C316&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/doctor-sleep-is-too-long-but-still-unsettling/">Doctor Sleep is Too Long but Still Unsettling!</a></h2>

					    					    	<span class="posted-date">November 8, 2019</span>
					    	<p>Doctor Sleep follows the decades-older Danny Torrance (Ewan McGregor) – now going by just Dan...</p>
	                		<a href="http://eclipsemagazine.com/doctor-sleep-is-too-long-but-still-unsettling/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/terminator-dark-fate-not-that-bad-michelles-review-spoiler-free/"><img width="474" height="267" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?fit=474%2C267" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91037" data-permalink="http://eclipsemagazine.com/terminator-dark-fate-not-that-bad-michelles-review-spoiler-free/phoenix-9/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?fit=5020%2C2824" data-orig-size="5020,2824" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;8&quot;,&quot;credit&quot;:&quot;Kerry Brown&quot;,&quot;camera&quot;:&quot;ILCE-9&quot;,&quot;caption&quot;:&quot;Linda Hamilton stars in Skydance Productions and Paramount Pictures&#039; \&quot;TERMINATOR: DARK FATE.\&quot;&quot;,&quot;created_timestamp&quot;:&quot;1531189722&quot;,&quot;copyright&quot;:&quot;\u00a9 2018 SKYDANCE PRODUCTIONS AND PARAMOUNT PICTURES. ALL RIGHTS RESERVED.&quot;,&quot;focal_length&quot;:&quot;171&quot;,&quot;iso&quot;:&quot;320&quot;,&quot;shutter_speed&quot;:&quot;0.002&quot;,&quot;title&quot;:&quot;PHOENIX&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="PHOENIX" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?fit=400%2C225" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?fit=474%2C267" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?w=5020 5020w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?resize=400%2C225 400w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?resize=768%2C432 768w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?resize=1024%2C576 1024w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?w=948 948w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?w=1422 1422w" data-lazy-sizes="(max-width: 474px) 100vw, 474px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/TerminatorDarkFate4.jpg?fit=474%2C267&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/terminator-dark-fate-not-that-bad-michelles-review-spoiler-free/">Terminator: Dark Fate, Not That Bad, Michelle&#8217;s Review Spoiler Free</a></h2>

					    					    	<span class="posted-date">November 3, 2019</span>
					    	<p>Terminator: Dark Fate wants to pretend like the last 4 or 5 sequels to T2,...</p>
	                		<a href="http://eclipsemagazine.com/terminator-dark-fate-not-that-bad-michelles-review-spoiler-free/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/terminator-dark-fate-is-a-surprisingly-fun-ride/"><img width="474" height="316" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/PHX_12088R2-e1572585482591.jpg?fit=474%2C316" class="attachment-large size-large wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91008" data-permalink="http://eclipsemagazine.com/terminator-dark-fate-is-a-surprisingly-fun-ride/phoenix/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/PHX_12088R2-e1572585482591.jpg?fit=750%2C500" data-orig-size="750,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;6.3&quot;,&quot;credit&quot;:&quot;Kerry Brown&quot;,&quot;camera&quot;:&quot;ILCE-9&quot;,&quot;caption&quot;:&quot;Arnold Schwarzenegger and Linda Hamilton star in Skydance Productions and Paramount Pictures&#039; \&quot;TERMINATOR: DARK FATE.\&quot;&quot;,&quot;created_timestamp&quot;:&quot;1539237511&quot;,&quot;copyright&quot;:&quot;\u00a9 2018 SKYDANCE PRODUCTIONS AND PARAMOUNT PICTURES. ALL RIGHTS RESERVED.&quot;,&quot;focal_length&quot;:&quot;40&quot;,&quot;iso&quot;:&quot;4000&quot;,&quot;shutter_speed&quot;:&quot;0.01&quot;,&quot;title&quot;:&quot;PHOENIX&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="PHOENIX" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/PHX_12088R2-e1572585482591.jpg?fit=400%2C267" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/PHX_12088R2-e1572585482591.jpg?fit=474%2C316" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/PHX_12088R2-e1572585482591.jpg?fit=474%2C316&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/terminator-dark-fate-is-a-surprisingly-fun-ride/">Terminator: Dark Fate Is a Surprisingly Fun Ride!</a></h2>

					    					    	<span class="posted-date">November 1, 2019</span>
					    	<p>Terminator: Dark Fate easily surpasses the low bar set by the third, fourth and fifth...</p>
	                		<a href="http://eclipsemagazine.com/terminator-dark-fate-is-a-surprisingly-fun-ride/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
		</div>

					</div>
		</div>
		</aside></div><!-- #content-sidebar -->
<div id="secondary">
		<h2 class="site-description">Entertainment News for The Rest of Us</h2>
	
	
		<div id="primary-sidebar" class="primary-sidebar widget-area" role="complementary">
		<aside id="pfcwidget-4" class="widget pfc-widget">
		<div class="pfc-posts-wrap">

			<h1 class="widget-title">Movie News</h1>
			<div class="pfc-posts-inner">

				
		<div class="pfc-posts-main">

			
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/"><img width="400" height="168" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?fit=400%2C168" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91885" data-permalink="http://eclipsemagazine.com/the-ultimate-stalker-trailer-the-invisible-man/the-invisible-man-2/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?fit=1192%2C500" data-orig-size="1192,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Universal Pictures&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;\u00a9 2020 Universal Pictures&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;THE INVISIBLE MAN&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="THE INVISIBLE MAN" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?fit=400%2C168" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?fit=474%2C199" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?w=1192 1192w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?w=948 948w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/2527_T1F_0001-e1580694140672.jpg?fit=400%2C168&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/">(Not) Free at Last Trailer: The Invisible Man!</a></h2>

					    <p>Five days later, there's a new, even creepier, trailer for...</p>
	                		<a href="http://eclipsemagazine.com/not-free-at-last-trailer-the-invisible-man/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/theres-something-in-the-skies-trailer-the-vast-of-night/"><img width="400" height="167" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/the-vast-of-night-TVONStill002_rgb-scaled-e1581014010642.jpg?fit=400%2C167" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91954" data-permalink="http://eclipsemagazine.com/theres-something-in-the-skies-trailer-the-vast-of-night/the-vast-of-night-tvonstill002_rgb/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/the-vast-of-night-TVONStill002_rgb-scaled-e1581014010642.jpg?fit=1200%2C500" data-orig-size="1200,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="the-vast-of-night-TVONStill002_rgb" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/the-vast-of-night-TVONStill002_rgb-scaled-e1581014010642.jpg?fit=400%2C167" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/the-vast-of-night-TVONStill002_rgb-scaled-e1581014010642.jpg?fit=474%2C198" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/the-vast-of-night-TVONStill002_rgb-scaled-e1581014010642.jpg?w=1200 1200w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/the-vast-of-night-TVONStill002_rgb-scaled-e1581014010642.jpg?w=948 948w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/the-vast-of-night-TVONStill002_rgb-scaled-e1581014010642.jpg?fit=400%2C167&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/theres-something-in-the-skies-trailer-the-vast-of-night/">There&#8217;s Something in the Skies Trailer: The Vast of Night!</a></h2>

					    <p>A young switchboard operator in a small New Mexico town...</p>
	                		<a href="http://eclipsemagazine.com/theres-something-in-the-skies-trailer-the-vast-of-night/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/introducing-disney%e2%80%a2pixars-beyond-new-ad-spot-and-behind-the-scenes-video/"><img width="400" height="167" src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Onward-2.png?fit=400%2C167" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91510" data-permalink="http://eclipsemagazine.com/new-trailer-character-posters-released-for-disney%e2%80%a2pixars-onward/onward-2-2/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Onward-2.png?fit=614%2C256" data-orig-size="614,256" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Onward 2" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Onward-2.png?fit=400%2C167" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Onward-2.png?fit=474%2C198" data-lazy-srcset="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Onward-2.png?w=614 614w, https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Onward-2.png?resize=400%2C167 400w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2019/12/Onward-2.png?fit=400%2C167&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/introducing-disney%e2%80%a2pixars-beyond-new-ad-spot-and-behind-the-scenes-video/">Introducing Disney•Pixar&#8217;s Beyond &#8211; New Ad Spot and Behind the Scenes Video!</a></h2>

					    <p>Disney•Pixar's Onward is the tale of teenage elf brothers on...</p>
	                		<a href="http://eclipsemagazine.com/introducing-disney%e2%80%a2pixars-beyond-new-ad-spot-and-behind-the-scenes-video/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/kid-power-trailer-minions-the-rise-of-gru/"><img width="400" height="200" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Minions-The-Rise-of-Gru-Banner.jpg?fit=400%2C200" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91927" data-permalink="http://eclipsemagazine.com/kid-power-trailer-minions-the-rise-of-gru/minions-the-rise-of-gru-banner/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Minions-The-Rise-of-Gru-Banner.jpg?fit=668%2C334" data-orig-size="668,334" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Minions &#8211; The Rise of Gru Banner" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Minions-The-Rise-of-Gru-Banner.jpg?fit=400%2C200" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Minions-The-Rise-of-Gru-Banner.jpg?fit=474%2C237" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Minions-The-Rise-of-Gru-Banner.jpg?w=668 668w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Minions-The-Rise-of-Gru-Banner.jpg?resize=400%2C200 400w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Minions-The-Rise-of-Gru-Banner.jpg?fit=400%2C200&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/kid-power-trailer-minions-the-rise-of-gru/">Kid Power Trailer: Minions: The Rise of Gru!</a></h2>

					    <p>Before he became a Good Guy, Gru was a Very...</p>
	                		<a href="http://eclipsemagazine.com/kid-power-trailer-minions-the-rise-of-gru/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/the-police-are-seeing-something-gruesomely-familiar-trailer-spiral/"><img width="400" height="72" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Spiral_Title_Treatment.jpg?fit=400%2C72" class="attachment-medium size-medium wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91923" data-permalink="http://eclipsemagazine.com/the-police-are-seeing-something-gruesomely-familiar-trailer-spiral/spiral_title_treatment/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Spiral_Title_Treatment.jpg?fit=1200%2C215" data-orig-size="1200,215" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Spiral_Title_Treatment" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Spiral_Title_Treatment.jpg?fit=400%2C72" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Spiral_Title_Treatment.jpg?fit=474%2C85" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Spiral_Title_Treatment.jpg?w=1200 1200w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Spiral_Title_Treatment.jpg?resize=400%2C72 400w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Spiral_Title_Treatment.jpg?resize=768%2C138 768w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Spiral_Title_Treatment.jpg?resize=1024%2C183 1024w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Spiral_Title_Treatment.jpg?w=948 948w" data-lazy-sizes="(max-width: 400px) 100vw, 400px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Spiral_Title_Treatment.jpg?fit=400%2C72&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/the-police-are-seeing-something-gruesomely-familiar-trailer-spiral/">The Police Are Seeing Something Gruesomely Familiar Trailer: Spiral!</a></h2>

					    <p>Someone is resurrecting the style of the murderer from the...</p>
	                		<a href="http://eclipsemagazine.com/the-police-are-seeing-something-gruesomely-familiar-trailer-spiral/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
		</div>

					</div>
		</div>
		</aside><aside id="pfcwidget-6" class="widget pfc-widget">
		<div class="pfc-posts-wrap">

			<h1 class="widget-title">Television News</h1>
			<div class="pfc-posts-inner">

				
		<div class="pfc-posts-main">

			
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/hip-hop-defiance-trailer-utopia-falls/"><img width="672" height="372" src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Utopia-Falls-e1581017359169.png?resize=672%2C372" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91962" data-permalink="http://eclipsemagazine.com/hip-hop-defiance-trailer-utopia-falls/utopia-falls/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Utopia-Falls-e1581017359169.png?fit=688%2C500" data-orig-size="688,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Utopia Falls" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Utopia-Falls-e1581017359169.png?fit=400%2C291" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Utopia-Falls-e1581017359169.png?fit=474%2C344" data-lazy-srcset="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Utopia-Falls-e1581017359169.png?zoom=2&amp;resize=672%2C372 1344w, https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Utopia-Falls-e1581017359169.png?zoom=3&amp;resize=672%2C372 2016w" data-lazy-sizes="(max-width: 672px) 100vw, 672px" data-lazy-src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/Utopia-Falls-e1581017359169.png?resize=672%2C372&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/hip-hop-defiance-trailer-utopia-falls/">Hip Hop Defiance Trailer: Utopia Falls!</a></h2>

					    					    	<span class="posted-date">February 6, 2020</span>
					    	<p>Every year, New Babyl stages a musical competition called the...</p>
	                		<a href="http://eclipsemagazine.com/hip-hop-defiance-trailer-utopia-falls/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/hbo-max-forms-film-production-arm/"><img width="672" height="372" src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/HBOMax.png?resize=672%2C372" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91937" data-permalink="http://eclipsemagazine.com/hbo-max-forms-film-production-arm/hbomax/" data-orig-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/HBOMax.png?fit=1184%2C542" data-orig-size="1184,542" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="HBOMax Launches Warner Pictures Group" data-image-description="" data-medium-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/HBOMax.png?fit=400%2C183" data-large-file="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/HBOMax.png?fit=474%2C217" data-lazy-src="https://i1.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/HBOMax.png?resize=672%2C372&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/hbo-max-forms-film-production-arm/">HBO Max Forms Film Production Arm!</a></h2>

					    					    	<span class="posted-date">February 5, 2020</span>
					    	<p>I have to say after 3 months I've been really...</p>
	                		<a href="http://eclipsemagazine.com/hbo-max-forms-film-production-arm/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/hbos-latest-comedy-series-run-coming-april-12/"><img width="672" height="372" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/HBO-Run-Wide.png?resize=672%2C372" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91932" data-permalink="http://eclipsemagazine.com/hbos-latest-comedy-series-run-coming-april-12/hbo-run-wide/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/HBO-Run-Wide.png?fit=729%2C421" data-orig-size="729,421" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="HBO Run Debuts April 12" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/HBO-Run-Wide.png?fit=400%2C231" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/HBO-Run-Wide.png?fit=474%2C274" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/HBO-Run-Wide.png?resize=672%2C372&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/hbos-latest-comedy-series-run-coming-april-12/">HBO&#8217;s Latest Comedy Series Run Coming April 12</a></h2>

					    					    	<span class="posted-date">February 5, 2020</span>
					    	<p>Written and produced by Vicky Jones, HBO’s new half-hour comedy...</p>
	                		<a href="http://eclipsemagazine.com/hbos-latest-comedy-series-run-coming-april-12/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/new-series-season-of-the-syndicate-coming-for-britbox/"><img width="672" height="372" src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Syndicate.jpg?resize=672%2C372" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91944" data-permalink="http://eclipsemagazine.com/new-series-season-of-the-syndicate-coming-for-britbox/the-syndicate/" data-orig-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Syndicate.jpg?fit=1280%2C872" data-orig-size="1280,872" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="The Syndicate" data-image-description="" data-medium-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Syndicate.jpg?fit=400%2C273" data-large-file="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Syndicate.jpg?fit=474%2C323" data-lazy-srcset="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Syndicate.jpg?resize=672%2C372 672w, https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Syndicate.jpg?resize=1038%2C576 1038w" data-lazy-sizes="(max-width: 672px) 100vw, 672px" data-lazy-src="https://i0.wp.com/eclipsemagazine.com/wp-content/uploads/2020/02/The-Syndicate.jpg?resize=672%2C372&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/new-series-season-of-the-syndicate-coming-for-britbox/">New Series/Season of The Syndicate Coming for Britbox!</a></h2>

					    					    	<span class="posted-date">February 5, 2020</span>
					    	<p>The BBC's drama series The Syndicate is returning for a...</p>
	                		<a href="http://eclipsemagazine.com/new-series-season-of-the-syndicate-coming-for-britbox/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
				<div class="pfc-post layout-two">
				
					
						<div class="news-thumb">

							<a href="http://eclipsemagazine.com/dinsey-orders-season-2-of-high-school-musical-the-musical-the-series/"><img width="672" height="372" src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/disney-logo-e1572628675472.jpg?resize=672%2C372" class="attachment-post-thumbnail size-post-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="91016" data-permalink="http://eclipsemagazine.com/dsineys-big-shot-adds-shiri-appleby-and-yvette-nicole-brown-to-cast/disney-logo-5/" data-orig-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/disney-logo-e1572628675472.jpg?fit=751%2C500" data-orig-size="751,500" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="disney+ logo" data-image-description="" data-medium-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/disney-logo-e1572628675472.jpg?fit=400%2C266" data-large-file="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/disney-logo-e1572628675472.jpg?fit=474%2C316" data-lazy-srcset="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/disney-logo-e1572628675472.jpg?zoom=2&amp;resize=672%2C372 1344w, https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/disney-logo-e1572628675472.jpg?zoom=3&amp;resize=672%2C372 2016w" data-lazy-sizes="(max-width: 672px) 100vw, 672px" data-lazy-src="https://i2.wp.com/eclipsemagazine.com/wp-content/uploads/2019/11/disney-logo-e1572628675472.jpg?resize=672%2C372&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>

						</div>
						
					<div class="news-text-wrap info-with-space">

					    <h2><a href="http://eclipsemagazine.com/dinsey-orders-season-2-of-high-school-musical-the-musical-the-series/">Disney+ Orders Season 2 of High School Musical: The Musical: The Series!</a></h2>

					    					    	<span class="posted-date">February 5, 2020</span>
					    	<p>Disney+ has renewed High School Musical: The Musical: The Series....</p>
	                		<a href="http://eclipsemagazine.com/dinsey-orders-season-2-of-high-school-musical-the-musical-the-series/" class="read-more">Read More</a>
	                						     
					</div><!-- .news-text-wrap -->

				</div>

				
		</div>

					</div>
		</div>
		</aside>	</div><!-- #primary-sidebar -->
	</div><!-- #secondary -->

		</div><!-- #main -->

		<footer id="colophon" class="site-footer" role="contentinfo">

			
			<div class="site-info">
												<a href="https://wordpress.org/" class="imprint">
					Proudly powered by WordPress				</a>
			</div><!-- .site-info -->
		</footer><!-- #colophon -->
	</div><!-- #page -->

		<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/eclipsemagazine.com\/not-free-at-last-trailer-the-invisible-man\/":91984};
	</script>
				<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
								<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
		<!-- `jetpack-carousel` is included in the concatenated jetpack.css -->
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/modules/wpgroho.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='http://eclipsemagazine.com/wp-content/themes/twentyfourteen/js/functions.js?ver=20150315'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/spin.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/jquery.spin.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"http:\/\/eclipsemagazine.com\/wp-admin\/admin-ajax.php","nonce":"d90ad08965","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"white","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"1","require_name_email":"1","login_url":"http:\/\/eclipsemagazine.com\/wp-login.php?redirect_to=http%3A%2F%2Feclipsemagazine.com%2Fnot-free-at-last-trailer-the-invisible-man%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<p id=\"jp-carousel-commenting-as\">You must be <a href=\"#\" class=\"jp-carousel-comment-login\">logged in<\/a> to post a comment.<\/p>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/postmessage.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/jquery.jetpack-resize.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/likes/queuehandler.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.1.1/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202006#ver=202006' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	<script type='text/javascript' src='https://stats.wp.com/e-202006.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.1.1',blog:'2511119',post:'91984',tz:'-4',srv:'eclipsemagazine.com'} ]);
	_stq.push([ 'clickTrackerInit', '2511119', '91984' ]);
</script>
</body>
</html>
